Skip to content
  • Bernd Kuhls's avatar
    package/gdb: Add optional dependencies · 23413b51
    Bernd Kuhls authored
    
    
    To allow reproducable builds of target gdb add some optional dependencies
    
    $ output/host/usr/bin/i586-buildroot-linux-uclibc-readelf -a output/target/usr/bin/gdb | grep NEEDED
     0x00000001 (NEEDED)                     Shared library: [libdl.so.0]
     0x00000001 (NEEDED)                     Shared library: [libncurses.so.5]
     0x00000001 (NEEDED)                     Shared library: [libz.so.1]
     0x00000001 (NEEDED)                     Shared library: [libm.so.0]
     0x00000001 (NEEDED)                     Shared library: [libiconv.so.2]
     0x00000001 (NEEDED)                     Shared library: [libpthread.so.0]
     0x00000001 (NEEDED)                     Shared library: [libutil.so.0]
     0x00000001 (NEEDED)                     Shared library: [libpython2.7.so.1.0]
     0x00000001 (NEEDED)                     Shared library: [libexpat.so.1]
     0x00000001 (NEEDED)                     Shared library: [libc.so.0]
    
    [Thomas: explicitly use --{with,without}-{expat,zlib}. There is no
    such option for libiconv, so for libiconv, the code was left as is.]
    
    Signed-off-by: default avatarBernd Kuhls <bernd.kuhls@t-online.de>
    Signed-off-by: default avatarThomas Petazzoni <thomas.petazzoni@free-electrons.com>
    23413b51