Skip to content
  • Bernd Kuhls's avatar
    package/ffmpeg: disable build of nvidia hardware acceleration support · 3b6fa452
    Bernd Kuhls authored
    ffmpeg always enables support for nvenc/cuda even if their support
    libraries are not present:
    
    External libraries providing hardware acceleration:
    cuda cuvid nvenc
    [...]
    Enabled hwaccels:
    h264_cuvid mjpeg_cuvid mpeg2_cuvid vc1_cuvid vp9_cuvid
    hevc_cuvid mpeg1_cuvid mpeg4_cuvid vp8_cuvid
    
    This leads to a crash in freeswitch git master when transcoding video
    streams on a system without nvidia hardware:
    
    2017-07-22 15:06:27.306760 [INFO] avcodec.c:1077 initializing encoder 352x288
    2017-07-22 15:06:27.306760 [NOTICE] avcodec.c:828 NVENC HW CODEC ENABLED
    
    This patch disables the support of nvidia hardware acceleration support
    for now until the needed packages are added to buildroot. For details
    about this please refer to https://developer.nvidia.com/ffmpeg
    
    
    
    Signed-off-by: default avatarBernd Kuhls <bernd.kuhls@t-online.de>
    Signed-off-by: default avatarThomas Petazzoni <thomas.petazzoni@free-electrons.com>
    3b6fa452