Skip to content
  • Peter Korsgaard's avatar
    ntp: does not work with libressl · f8bff449
    Peter Korsgaard authored
    
    
    Fixes #10556
    
    The --with-crypto handling in ntp only works with libopenssl, not with
    libressl, where it ends up with compilation issues like:
    
    ntp_control.c:(.text+0x64): undefined reference to `EVP_MD_CTX_new'
    ntp_control.c:(.text+0x10c): undefined reference to `EVP_MD_CTX_free'
    libntpd.a(ntp_crypto.o): In function `bighash':
    ntp_crypto.c:(.text+0x2e8): undefined reference to `EVP_MD_CTX_new'
    ntp_crypto.c:(.text+0x328): undefined reference to `EVP_MD_CTX_free'
    libntpd.a(ntp_crypto.o): In function `crypto_verify':
    ntp_crypto.c:(.text+0x6cc): undefined reference to `EVP_MD_CTX_new'
    ntp_crypto.c:(.text+0x710): undefined reference to `EVP_MD_CTX_free'
    ntp_crypto.c:(.text+0x72c): undefined reference to `EVP_MD_CTX_free'
    
    So ensure we only pass --with-crypto when libopenssl is used.
    
    Signed-off-by: default avatarPeter Korsgaard <peter@korsgaard.com>
    Signed-off-by: default avatarThomas Petazzoni <thomas.petazzoni@free-electrons.com>
    (cherry picked from commit 522111f81c7d535f4f362ad4a15d141d0eb39ec5)
    Signed-off-by: default avatarPeter Korsgaard <peter@korsgaard.com>
    f8bff449