Skip to content
  • Bernd Kuhls's avatar
    package/weston: fix build with OpenGL ES disabled · 1d297433
    Bernd Kuhls authored
    
    
    Building this defconfig
    
    BR2_TOOLCHAIN_BUILDROOT_LOCALE=y
    BR2_TOOLCHAIN_BUILDROOT_CXX=y
    BR2_ROOTFS_DEVICE_CREATION_DYNAMIC_EUDEV=y
    BR2_PACKAGE_MESA3D=y
    BR2_PACKAGE_MESA3D_DRI_DRIVER_I965=y
    BR2_PACKAGE_MESA3D_OPENGL_EGL=y
    BR2_PACKAGE_WESTON=y
    BR2_PACKAGE_XORG7=y
    
    is broken:
    
      CC       clients/weston_simple_dmabuf_drm-simple-dmabuf-drm.o
    clients/simple-dmabuf-drm.c: In function 'create_display':
    clients/simple-dmabuf-drm.c:758:15: warning: implicit declaration of function 'eglQueryString' [-Wimplicit-function-declaration]
      extensions = eglQueryString(EGL_NO_DISPLAY, EGL_EXTENSIONS);
                   ^~~~~~~~~~~~~~
    clients/simple-dmabuf-drm.c:758:30: error: 'EGL_NO_DISPLAY' undeclared (first use in this function)
      extensions = eglQueryString(EGL_NO_DISPLAY, EGL_EXTENSIONS);
                                  ^~~~~~~~~~~~~~
    clients/simple-dmabuf-drm.c:758:30: note: each undeclared identifier is reported only once for each function it appears in
    clients/simple-dmabuf-drm.c:758:46: error: 'EGL_EXTENSIONS' undeclared (first use in this function)
      extensions = eglQueryString(EGL_NO_DISPLAY, EGL_EXTENSIONS);
                                                  ^~~~~~~~~~~~~~
    clients/simple-dmabuf-drm.c:759:21: warning: implicit declaration of function 'weston_check_egl_extension' [-Wimplicit-function-declaration]
      if (extensions && !weston_check_egl_extension(extensions,
    
    Signed-off-by: default avatarBernd Kuhls <bernd.kuhls@t-online.de>
    Signed-off-by: default avatarThomas Petazzoni <thomas.petazzoni@free-electrons.com>
    (cherry picked from commit be420d12f10d5b2c9c5d3675c73b2dffc3a66e3c)
    Signed-off-by: default avatarPeter Korsgaard <peter@korsgaard.com>
    1d297433