Skip to content
  • Zakharov Vlad's avatar
    gdb: arc: remove C++ dependency and disable build with C++ · ca99d0ea
    Zakharov Vlad authored
    gdb arc-2016.09-rc1 is based on upstream 7.12 gdb version where we can
    still disable C++ build. For more information take a look at:
    https://sourceware.org/gdb/wiki/cxx-conversion
    
    
    
    We wanted to build gdb with C++ as it is used as default in 7.12
    and is even a mandatory requirement since 2016/09.
    
    But unfortunately we missed one runtime failure that C++ build causes
    and so now we have to disable C++ build.
    
    When gdb arc-2016.09-rc1 is built as a C++ application it segfaults at
    runtime for ARC.
    
    We are going to fix the issue in 2017.03 ARC toolchain release.  and
    before this we remove C++ dependency are adding temporary workaround
    to prevent runtime segfaults.
    
    The workaround is to disable building gdb as C++ application via
    passing --disable-build-with-cxx config option when building gdb for
    ARC.
    
    Signed-off-by: default avatarVlad Zakharov <vzakhar@synopsys.com>
    Signed-off-by: default avatarThomas Petazzoni <thomas.petazzoni@free-electrons.com>
    ca99d0ea